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1

Introduction
Congratulations on purchasing your IPC@CHIP DK61 Development Kit. The Development Kit
is a complete ready-to-use development system for building applications based on the
Embedded Web Controllers IPC@CHIP SC123 and IPC@CHIP SC143. It runs with the
@CHIP-RTOS operating system, which includes features like a real-time kernel that is capable
of running common DOS applications concurrently, a full TCP/IP stack with a UDP/TCP socket
interface, DHCP, FTP, PPP, Telnet, Web server etc, APIs for CAN and USB controllers, etc.
The Development Kit contains both hardware and software components required for a basic
development. This document will introduce you to the several components of the DK61.
Chapter 2 provides a step-by-step guide on how to put the DK61 into operation. Chapter 3
describes selected components of the DK61 for advanced users. Chapter 4 points the way to
further information.

2

System Start-up

2.1

What do we need to get started?
-

-

-

The Development Kit DK61 consisting
of:
o Development Board DK60
o Embedded Web Controller
IPC@CHIP SC143 (on the
DK60)
o Serial null-modem cable
o USB cable (A-to-Mini-B)
o Ethernet patch cable(gray) 1
o Ethernet crossover cable(red)
o Secure digital memory card
o Power supply unit
o Paradigm C++ Beck IPC
Edition CD (including
IPC@CHIPTOOL, DEBUG@CHIP debugger,
DK61 startup documentation and drivers)
o The enclosed CoDeSys CD is not needed within the context of this manual.
Personal Computer
o Microsoft Windows NT/2000/XP Operating System
o Ethernet network interface
o Serial port
o USB interface
Software from the enclosed Paradigm CD or the IPC@CHIP Getting Started Website at
http://www.beck-ipc.com/gettingstarted
o DK60 Visualisation Demo
o Driver software
Be aware that the Embedded Controller SC143 and the
Development Board DK60 are electrostatic sensitive
components. Observe general precautions for handling.

1

Ethernet cables and the SD memory card are part of delivery since DK61 version H01
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2.2

Step 1 – Switching on the DK60 Development Board
The Development Kit DK61 is designed to give you easy access to the functionality of the
IPC@CHIP SC143, especially to its several interfaces like serial ports, Ethernet, digital I/O,
CAN, USB, etc.
The following graphic gives an overview of the most important components of the DK60.

The AC power supply is delivered with country specific AC adapters. Please choose the right
adapter for your country. Then connect the AC power supply to your main supply and to the
DK60 Development Board to power it. The Power LED will light up.

2.3

Step 2 – Starting the IPC@CHIPTOOL
The IPC@CHIPTOOL is your communication centre for all IPC@CHIP-based products. It
provides functionality for finding IPC@CHIPs on the network, configuring them, updating their
RTOS, transferring files and using their shell.
For installing IPC@CHIPTOOL at your PC execute the Chiptool setup program
Chiptool_Install.Exe from the Tools section of the CD or from the Getting Started webpage.
After the installation, you are able to start the IPC@CHIPTOOL application.
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In the main window you can see all IPC@CHIPs that could be found on the network. The table
displays information such as serial number, name, IP configuration and RTOS version. The
main menu provides functionality such as the terminal and an FTP-Client which you will need
later on in the Getting Started process.
The following graphic shows only part of the main window.

The IPC@CHIPTOOL comes along with a detailed help. Simply press F1 in the main window
for further information.
If you’re running a firewall, make sure that it does not block any network functions of
IPC@CHIPTOOL such as Telnet, FTP or the scanning for IPC@CHIPs.

2.4

Step 3 – Setting up communication
There are basically three ways to connect your DK61 to your PC: the serial interface, Ethernet
and USB.
The simplest connection type is the serial interface. Preferably use it to get access to the shell
of your IPC@CHIP.
Ethernet communication is the most powerful. It may be used to access the shell via Telnet
and it’s the easiest way to transfer files to the IPC@CHIP via FTP.
USB is an alternative to the serial interface. It provides nearly the same facilities as the serial
interface. Use it if your PC does not dispose of a serial interface. USB connectivity is not
available before separate software has been deployed on the IPC@CHIP. Therefore setting up
USB communication is described later in chapter 2.7 of this document.
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2.4.1

Setting up the serial communication
To set up serial communication to your Development Kit DK61 you need the enclosed nullmodem cable.
1. Connect the null-modem cable to a free serial port of your PC and with the COM1 interface
of the DK61.
2. Choose Tools → Terminal from the IPC@CHIPTOOL main menu
3. In the connection dialog that now opens choose the following settings:
o Connection Type: Serial
o Port: The serial port of your PC that you connected the null-modem cable to, e.g.
COM1
o Baudrate: 19200
4. Press Connect to open the connection

5. You’re now connected to your IPC@CHIP. Press Return to see the prompt.
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You may now use the commands of the @CHIP RTOS’ shell. The command DIR will, for
example, display a list of the files shipped on your IPC@CHIP.

2.4.2

Setting up the Ethernet communication
Network communication is based on the TCP/IP protocol family. To be able to operate in a
TCP/IP network, your IPC@CHIP needs to be assigned a valid and unambiguous IP address
and network mask. If you cannot figure out a proper IP address and network mask for your
IPC@CHIP, please consult your network administrator.
There are two ways of assigning an IP address to your IPC@CHIP SC143. You may either
configure it by hand or you may use DHCP to automatically assign IP settings. Of course you
will need a DHCP-Server to achieve the latter.
The default configuration for the IPC@CHIP is using DHCP since this will ensure that the
IPC@CHIP adapts to an existing network if this network disposes of a DHCP server. If your
network doesn’t possess a DHCP server, the IPC@CHIP will not disturb the operation of your
network.
If you have a regular local network with several clients, connect the DK61’s Ethernet interface
ETH0 to your Ethernet hub or switch using the enclosed twisted pair patch cable (gray) and go
on to section 2.4.2.1 or 2.4.2.2 depending on how you’d like to assign IP settings to your
IPC@CHIP.
If you’re not connected to a network but want to connect the DK61 directly to your PC, you
have to use the enclosed cross-over twisted pair Ethernet cable (red) to plug the DK61’s
Ethernet interface ETH0 to your PC’s Ethernet interface. Then go on to section 2.4.2.2.
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2.4.2.1

IP address configuration via DHCP
In a network supporting DHCP the IPC@CHIP retrieves a valid IP configuration from a DHCP
server automatically.
Press the Reset button of your DK61. On the terminal window you will get displayed the boot
messages. Here you will see the serial number, @CHIP-RTOS version, build date and other
information. If an IP configuration could be successfully received from the DHCP server, this IP
configuration will be displayed at the end of the boot messages. In the event of an error, the
message DHCP request failed will be put out after a few seconds.

2.4.2.2

IP address configuration by hand
The easiest way to configure your IPC@CHIP’s IP settings by hand is to use the functionality
of the IPC@CHIPTOOL software. In a network without DHCP server your IPC@CHIP should
be displayed as Not configured since by default DHCP is enabled but no server could be
found.

© 2006 Beck IPC GmbH
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1. Right-click on your IPC@CHIP.
2. Select IP configuration from the pop-up menu.
3. In the appearing dialog fill the fields IP Address, Network mask and, if necessary, Gateway
with appropriate values.
4. Uncheck Use DHCP and check Configure always default Ethernet.
5. Press the Config button to apply the new settings to your IPC@CHIP.

6. Close the dialog and go back to the main window. It now shows the new IP configuration.
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2.4.2.3

Using Telnet to access the shell
Instead of using the serial terminal as described in section 2.4.1 to operate the shell of the
@CHIP RTOS you may use Telnet. Once the IP configuration of your IPC@CHIP is
completed, simply perform the following steps:
1. Right-click on your IPC@CHIP in the main window.
2. Select Telnet from the pop-up menu.
3. The appearing connection dialog is already filled with the right IP address. Complete the
fields User and Password (Automatically login has to be checked) with tel each and click
Connect.

4. You’re now logged in to your IPC@CHIP. Press Return to see the prompt.
You may use telnet just like the serial terminal but the connection will be closed if the
IPC@CHIP restarts.

© 2006 Beck IPC GmbH
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2.5

Step 4 – Downloading the DK60 Online demo program
First of all, you should download and extract the DK60Demo.ZIP archive from the Getting
Started section of the CD or from the Getting Started webpage to the local hard drive of your
PC.
To transfer files to and from your IPC@CHIP as easy as possible the IPC@CHIPTOOL
includes a simple FTP-Client. This can be used to connect to the @CHIP RTOS’ FTP-Server.
To open a connection, simply follow these steps:
1. Right-click on your IPC@CHIP once again in the CHIPTOOL main window.
2. Select FTP from the pop-up menu.
3. Another connection dialog appears. It’s already filled with the respective IP address.
Complete the fields User and Password each with ftp.

4. Press the Connect button to establish the connection.
5. You now see the main window of the FTP-Client with your local drive on the left side and
the IPC@CHIP’s flash drive on the right. The content of the chip’s drive may vary
depending on how you’ve configured your IP settings.
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You will now upload the DK60 Visualisation Demo that is further described in section 2.6.
6. In the left pane move to the directory where you have stored the Visualisation Demo.
7. Now change to the subdirectory Image of the extracted DK60 Visualisation Demo, which
contains all files that have to be deployed on the IPC@CHIP.
8. Select all files in the image directory.
9. Right-click on one of the files and select Copy from the pop-up menu.
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The Visualisation Demo will now be copied to the IPC@CHIP. If the FTP-Client notifies you
that a file named CHIP.INI already exists, overwrite it. You will then have to repeat the IP
configuration described in section 2.4.2 after rebooting the chip. The file CHIP.INI includes
information such as the IP settings.
10. After all files have been copied, select Connection → Close from the menu.
11. Close the FTP-Client.
The FTP-Client provides much more functions than just transferring files. You may also create
and remove directories or edit text files situated on the IPC@CHIP such as the CHIP.INI.
The handling should be quiet intuitive.

2.6

Step 5 – Operating the Demo program
To activate the Visualisation Demo you just transferred in section 2.5, reboot the IPC@CHIP
by pressing the DK61’s Reset button. The Visualisation Demo is now accessible via the
IPC@CHIP’s web server.
Right click on your IPC@CHIP in the IPC@CHIPTOOL’s main window and select HTTP from
the pop-up menu. This will open your browser and show the main page of the IPC@CHIP
which now is the Visualisation Demo.

The Visualisation Demo provides three techniques to visualise and modify the digital I/Os of
the DK61 – a Java Applet, a Flash Movie and a plain HTML/CGI Page. The Java Applet as
well as the Flash Movie show a picture of the DK60 plate with a magnifier above the I/Os.
These change their colour depending on their state. You may click the output LEDs in order to
toggle them.
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Of course the appropriate browser plug-ins have to be installed for the Java Applet or the
Flash Movie to work.
The HTML/CGI Page provides the same functionality but not graphically visualised.
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2.7

Step 6 – Setting up USB connection
If your PC does not dispose of a serial interface you can instead use the USB interface of the
DK61 to establish a serial connection. You need to copy and extract the USBTERM.ZIP
archive from the Getting Started section of the CD or from the Getting Started webpage to the
local hard drive of your PC.
The extracted archive also contains the USB Terminal Emulation software.
1. Copy the file USBTERM.EXE to the root directory of your IPC@CHIP using the CHIPTOOL
FTP-Client.
2. Right-click the file AUTOEXEC.BAT from the IPC@CHIP’s flash drive. (If none exists,
create an empty file on your local drive and transfer it to the IPC@CHIP.)
3. Select Edit from the pop-up menu.
4. An editor will open. Add the filename USBTERM.EXE in a new line. This will start the driver
on boot.
5. Save the file and close the Editor. The file will automatically be reloaded to the chip.
6. Plug the USB Device Interface (Mini-B jack) of your Development Board DK61 into your
PC’s USB interface.
7. Reboot your DK61 by pressing its Reset button.
8. Your PC will notice a new USB device and show a message in the system tray.

9. Select in the first window of the wizard No, not this time and click the Next button.
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10. In the second window of the wizard select Install from a list or specific location (Advanced)
and click Next.

11. In the third dialog of the wizard choose Search for the best driver in these locations, check
Include this location in the search and enter below the path of the driver configuration file
USBTERM.INF. Click the Next button. Windows will now configure a virtual serial port.
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12. Close the wizard.
13. Open the Windows Device Manager by pressing the Windows-key + Break, switching to
the Hardware tab and pressing the button Device Manager.
14. Open the section Ports (COM & LPT) to check which COM port was assigned (e.g.
COM5).

15. Open the IPC@CHIPTOOL’s terminal and establish a connection via this COM port.
Please note that the Windows driver which handles virtual serial devices such as the
USB Terminal Emulation is not that robust. Avoid unplugging or restarting your DK61
while you have a connection established via the virtual COM port.
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2.8

Step 7 – Configuring Compact Flash/SD/MMC-Card
To use a Compact Flash 2 or the enclosed SD/MMC-Card you’ll need additional software from
the Getting Started section of the CD or from the Getting Started website. The driver program
needed with Compact Flash Cards is named EXTIDE.EXE, the one needed with SD/MMCCards EXTSD.EXE.
Important: If you have downloaded the driver from the Getting Started webpage, please take
the drivers from the subdirectory Paradigm24.
1. Open the IPC@CHIPTOOL FTP-Client and transfer the respective driver file to the root
directory of your IPC@CHIP.
2. Right-click the file AUTOEXEC.BAT from the IPC@CHIP’s flash drive. (If none exists,
create an empty file on your local drive and transfer it to the IPC@CHIP.)
3. Select Edit from the pop-up menu.
4. An editor will open. Add the filename of the respective driver in a new line. This will start
the driver on boot.
5. Save the file and close the Editor. The file will automatically be reloaded to the chip.
6. Close the FTP-Client.
7. Unplug the power supply of the DK61.
8. Insert the respective card. Caution: Never exchange Compact Flash cards while the DK61
is running. SD/MMC-Cards can be changed at runtime.
9. Re-plug the power supply.
10. After booting the IPC@CHIP will dispose of a drive B: which represents the content of the
card. You can access this drive from the shell or via FTP.
Use the command B: to change to the cards file system from the shell. In the FTP-Client
you may use the drive selection box to change to drive B.

2

A compact flash card is not part of the DK61 Kit.
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The EXTIDE.EXE and EXTSD.EXE support several command line options which are needed if
you want to mount a certain partition on the card or if you want to use several external disk
drivers at once. These command line options are described in the source code files of the
corresponding driver. These source code files may not be situated on the Getting Started CD.
Please check out the download section of our website in this case.
Note that there is also an EXTUSB.EXE driver for USB mass storage devices. This driver can
also be found on our website.

2.9

Step 8 – Configuring the second Ethernet interface
The DK61 possesses a second Ethernet interface which can be activated and used with a
separate driver program. This driver can be taken from the Getting started section of the CD or
downloaded from the Getting Started website. Take the following steps to set up the second
Ethernet interface:
1. Connect the second Ethernet interface (ETH1) with a twisted-pair patch cable to your
network hub.
2. Open the IPC@CHIPTOOL FTP-Client and transfer the file ETH1.EXE to the
IPC@CHIP’s root directory.
3. Right-click the file AUTOEXEC.BAT from the IPC@CHIP’s flash drive. (If none exists,
create an empty file on your local drive and transfer it to the IPC@CHIP.)
4. Select Edit from the pop-up menu.
5. An editor will open. Add the following line to the file.
ETH1.EXE XXX.XXX.XXX.XXX YYY.YYY.YYY.YYY
Replace XXX.XXX.XXX.XXX by the IP address for the second interface and
YYY.YYY.YYY.YYY by the network mask. This will start the driver on boot.
If you want the second Ethernet interface to be configured automatically by DHCP, simply
leave out the arguments.
6. Save the file and close the Editor. The file will automatically be reloaded to the chip.
7. Close the FTP-Client.
8. Reboot the DK61 by pressing its Reset button. You may now use the second Ethernet
interface with the respective IP settings.
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3

Information for advanced users

3.1

Updating the @CHIP RTOS
You can download updates for your IPC@CHIP’s RTOS from our website. These updates may
then easily be applied using IPC@CHIPTOOL.
1. Right-click on your IPC@CHIP in the main window of CHIPTOOL.
2. Select Program flash image from the pop-up menu.
3. The Program flash image dialog will appear.
4. Fill the field Load file with the path of the RTOS hex file. You may use the button on the
left to open a file browsing dialog.
You now have two options to load the update to your IPC@CHIP. If you want to load the hex
file via the serial interface follow the steps on the left, if you prefer uploading it via Ethernet
follow the steps on the right. Loading the update via the serial interface should always work.
An Ethernet update presumes a running RTOS. So if your RTOS does not boot any more you
have to use the serial update.
5. Connect the COM0 interface of your
DK61 with a serial interface of your PC.
6. Select the respective COM port in the
port selection box.
7. Press the Start button in the section Use
RS-232 interface.
8. Press the Reset button of your DK61 to
reboot your IPC@CHIP.
9. Wait for the update to complete.

5. Make sure your DK61 is connected to
your network.
6. Make sure the field Serial number or
MAC-ID or IP address of IPC@CHIP is
filled correctly.
7. Press the Start button in the section Use
TCP/IP UDP.
8. Wait for the update to complete.
If you are connected to the shell of your
IPC@CHIP while performing an Ethernet
update, you will see a lot of ‘P’ characters
while the flash is programmed.
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Note that in some cases an RTOS update will overwrite your IPC@CHIP’s file system which
will lead to loss of data possibly including the IP configuration of the IPC@CHIP. If you have
done the update via Ethernet this may cause some error messages since CHIPTOOL will try to
find the IPC@CHIP on the network after an Ethernet update. You’ll then have to reconfigure
the chip’s IP configuration.
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Page 21 of 34

IPC@CHIP DK61
Getting Started V1.5

3.2

Developing Software for your IPC@CHIP
Though the IPC@CHIP SC123/SC143 features a 16-bit Processor you can no longer run
standard 16-bit DOS applications on it. This is due to the extension of the address bus from 20
to 24 bits, which was needed to address more than 1MB of flash and/or RAM memory. The
IPC@CHIP SC123/SC143 possesses its own executable format which runs in the so-called
Extended Mode or 24-bit Mode.
Your existing IPC@CHIP applications will though run on the new SC123/SC143 after they
have been re-compiled.
The DK61 Development Kit includes the Paradigm C++ Beck IPC Edition Development
Environment with a compiler that produces executables in the above format. You will now
implement and deploy your first program on your DK61 Development Kit. It is presumed that
you have installed the Paradigm C++ Beck IPC Edition IDE from the enclosed CD.
1. Start the Paradigm IDE. You’ll see the main window.
2. Select File → New → Project… from the main menu to create a new project.

3. Complete the appearing dialog as follows:
Project Path and Name: Enter the directory and name where you want to save the project.
You may use the Browse button.
Target name: Leave as automatically set
Target Type: Application [.exe]
Platform: Extended address mode
Target Model: Large
Target Connection: No debugging
Math Support: None
No Exceptions: Checked
Controller Hardware: SC123/SC143
4. Press the OK button to create the project.
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5. Now double-click the filename HELLO.C in the project view on the left to open the source
file.
6. For this example you’ll now implement a simple “Hello World!” text output. Add the
following line to the main() function.
helper_printf( "Hello World!" );
The function helper_printf() is part of the IPC@CHIP C-API which will automatically
be integrated in each of your projects.

To get help on a specific function from the IPC@CHIP C-API simply press F1. A description of
the respective function will open in your web browser. An overview of the whole API can be
found in the main menu of the Paradigm C++ Beck IPC Edition IDE under Help → Help Files →
Beck → IPC@CHIP documentation index.
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7. Press F9 to make the project. The compiler will do its work and then show a success
message. A file called HELLO.EXE has now been created in the project directory.

8. Now start the IPC@CHIPTOOL FTP-Client to transfer the executable file to your
IPC@CHIP.
9. Open a terminal and type the filename to start the program.

To facilitate the process of compiling, transferring and starting your applications check
out the Postmake tool from our website.
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3.3

Debugging your IPC@CHIP applications
You may debug your IPC@CHIP applications using the integrated debugger of the Paradigm
C++ Beck Edition development environment. It communicates with the server program
PROBE.EXE which must run on the IPC@CHIP. So first you have to load this program to the
chip (using the IPC@CHIPTOOL FTP-Client) and start it. It’s situated in the subdirectory
BECKPROBE of the Paradigm C++ Beck Edition installation directory. It is recommended to
start the server program via the AUTOEXEC.BAT while debugging your applications, because
the debugger may reboot your IPC@CHIP autonomously.
To make your applications debug-able you need to change some settings in your project.
1. Select Options → Project… from the Paradigm C++ Beck Edition’s main window.
2. Open the section Compiler → Debugging in the appearing dialog and check the settings
Line numbers and Generate debug information.

3. Now open the section Linker → General and check the setting Include debug information.
4. Close the Project Options dialog by clicking OK.
After recompiling the project your executable file includes all information that the debugger
needs to enable source-level debugging. Make sure you don’t pack the executable file if you
want to debug it.
Next you have to set up the communication options for the connection to the server program.
1. Right-click on the executable file’s name in the project view and select TargetExpert…
from the pop-up menu.
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2. In the TargetExpert dialog change the field Target Connection to Beck probe.

3. Click on the Configure Settings button. The Communication Options dialog appears.
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4. Select TCP/IP socket and enter the IP address of your IPC@CHIP. Don’t change the Port
number.
5. Confirm as well the Communication Options dialog as the TargetExpert dialog.
You are now ready to debug your program.
1. Click in the source file window on the grey area in the left-most position to add a
breakpoint. A breakpoint symbol will appear and the respective source line will get a red
background.

2. Start your program by selecting Debug → Run from the menu. The debugger will connect
to the probe server program and if necessary compile and download the program. It will
then be executed up to the instruction where you’ve set the breakpoint. An arrow will point
to the respective line which will have a blue background now.
© 2006 Beck IPC GmbH

Page 27 of 34

IPC@CHIP DK61
Getting Started V1.5
3. Single-Step through your program. Each time you press F8 now, one instruction of your
program will be executed and the instruction pointer (arrow and blue background) will
move on to the next instruction.

4. When you’re done, select Debug → Terminate debug session from the menu.
The debugger provides much more functionality, but this goes beyond the scope of this
Getting Started document. Refer to the Paradigm C++ User’s Guide that can be found in the
main menu under Help → Reference → Paradigm C++ User’s Guide.
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3.4

Miscellaneous
This chapter contains miscellaneous information on the @CHIP RTOS.

3.4.1

The CHIP.INI configuration file
The @CHIP-RTOS holds its non-volatile configuration information in a file named CHIP.INI
found in the root directory of the flash disk drive. This ASCII text file can be adjusted either
directly with the edit function of the CHIPTOOL FTP-Client or with particular commands from
the terminal. The figure below shows a few example entries that might be found in a
CHIP.INI file.

Refer to the @CHIP-RTOS API Documentation for a complete specification of the entries
possible in this configuration file.

3.4.2

The command shell
The @CHIP-RTOS has a command shell task which accepts commands from a standard I/O
device. This standard I/O device can be either or both of the serial ports COM0 and COM1,
the Telnet port and, if the respective driver is started, the USB Device port. The selection is
controllable from the CHIP.INI file.
The standard I/O can be configured to be shared between application programs and the
@CHIP-RTOS command shell. A hot key (by default Ctrl + F) will switch the standard I/O focus
between application and @CHIP-RTOS command shell.
The HELP command gives an overview of all commands. Refer to the IPC@CHIP API
Documentation for a detailed description of the shell commands.
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3.4.3

The web server
The @CHIP-RTOS includes a web server via which you can access HTML pages situated on
your IPC@CHIP’s flash with your web browser. These HTML pages may include multi-media
content such as images, Java Applets, Flash movies and more. The web server also includes
a CGI interface. This allows the creation of pages with dynamic content in your applications.
To achieve this, a certain function is registered with the web browser that will be called if a
certain web address is requested. This function will then build the page.
By default there are two active CGI pages on your IPC@CHIP. One of them, the main page, is
disabled when uploading the DK60 Visualisation Demo. The second one is still accessible
under the address http://172.30.10.43/ChipCfg, assuming that 172.30.10.43 is your
IPC@CHIP’s IP address. This page shows some more or less useful information on the chip’s
configuration.
When creating your own web pages for your IPC@CHIP use the DK60 Visualisation Demo as
an example.
@CHIP RTOS also features a SSL (Secure Socket Layer) web server. SSL uses
cryptographic methods to establish a trusted connection between the SSL web server and the
browser, which makes it impossible for third parties to spy on or manipulate transferred data.
To set up the SSL web server you need a certificate which identifies your IPC@CHIP
unambiguously to the user. You may create such a certificate yourself or buy one from a socalled Certification Agency. This agency then signs the certificate and guarantees its
authenticity. To register the certificate with the web server and enable the SSL functionality
you have to use the CHIP.INI configuration file. Besides the certificate which consists of two
files, you need to generate a file containing private and public keys used with the cryptographic
functions.

3.4.4

The PPP server/client
PPP (the Point to Point Protocol) is a mechanism for running TCP/IP over a serial link - be that
a direct serial connection (using a null-modem cable), or a link made using an analogue
modem.
Other computers can dial into the IPC@CHIP PPP server and communicate via the TCP/IP
link using FTP, Telnet, HTTP, etc. in the same manner as with an Ethernet TCP/IP link. One
major difference between a PPP and an Ethernet connection is of course the speed. The
IPC@CHIP’s Ethernet interfaces operate at 100 mbps, whereas an analogue modem operates
at speeds up to 56 kbps.
PPP is strictly a peer to peer protocol. There is no difference between the machine that dials in
and the machine that is dialled into. However, it is still useful to think in terms of servers and
clients. When you dial into a site to establish a PPP connection, you are considered the client.
The machine to which you connect (e.g. the IPC@CHIP) is considered the server. The
@CHIP-RTOS operating system provides TCP/IP API functions for either side of this
client/server relationship.
PPP at the IPC@CHIP includes the sub protocols LCP and NCP (IPCP). Supported
authentication protocols are PAP and CHAP.
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3.4.5

New features in Paradigm C++ Beck IPC Edition
If you have by now developed IPC@CHIP applications using the Borland C++ 5.02 IDE, you
surely will appreciate the new features of the Paradigm C++ Beck IPC Edition, which make
software development more comfortable and effective.
Visual Assist
Paradigm C++ Beck Edition supports Visual Assist which observes what you type into the
editor and suggests terms that you could mean. So you don’t have to write out long function or
variable names but only type the first characters and press Return when Visual Assist knows
what you mean.

Visual Assist also features a small panel on top of the editor window where you can see the
definition of functions or variables that you are currently using. You may even directly jump to
the respective source file by simply clicking the Goto button.

Integrated Online Help for @CHIP RTOS API Documentation
The API Documentation for the @CHIP ROTS’ C-library is now integrated into the
development environment. When the text cursor is on any C-library term, simply press F1 to
open the respective documentation in your browser.
Smaller executable files
The Paradigm compiler produces executable code that is on the average 12 percent smaller
than the code produced by the Borland compiler. This saves a lot of space on your
IPC@CHIP’s flash drive.
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3.4.6

IPv4 Basics
On an IP network IP addresses are used to define the source and the destination of a data
packet. An advantage of IP addresses is that they also hold information on a device’s physical
location in a large network. This is best explained by an example:
Suppose you have the address 172.30.10.43 and the network mask 255.255.240.0. Let’s look
at this data in binary format:

IP address
Network mask
Logical AND of both

172.30.10.43
255.255.240.0

10101100.00011110.00001010.00101011
11111111.11111111.11110000.00000000
10101100.00011110.00000000.00000000

The first 20 bits of the network mask are 1. This means that the first 20 bits of the IP address
identify the network. The last 12 bits (those that are 0 in the network mask) identify the device
within this network. This means that in the given example we can give the devices in our
network the addresses 172.30.0.1 through 172.30.15.254. The lowest (here 172.30.0.0) and
the highest address (here 172.30.15.255) of a network are reserved and cannot be assigned
to a host. The lowest address identifies the network, the highest one is a broadcast address,
used for a broadcast to all devices on this section of the network. Messages sent to this
address are received by all devices.
Any address that is not within the range of the current network is passed to the gateway
address (the router). A gateway is a physical machine, hardwired into two or more physical
networks. It knows how to transfer an IP packet from one network to another.
You can find the network configuration of the network that you are connected to by entering
the command IPCONFIG in a Windows command shell.

On a network, no two devices are allowed to have the same address.
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3.4.7

IPv4/v6 Dual Stack
In addition to the IPv4 protocol, the TCP/IP protocol stack of the IPC@CHIP SC123/SC143
provides IPv6.
IPv6 is sometimes called the Next Generation Internet Protocol, or IPng. The current Internet
and most of corporate or private intranets use IPv4, developed in 1970s and 1980s. Now with
IPv6, the first significant upgrade of the Internet protocol has been started. The compelling
reason behind the formation of IPv6 was lack of address space, especially in the heavily
populated countries of Asia such as China.

•
•

The most important changes from IPv4 to IPv6 can be summarized as follows:
Expanded addressing and auto configuration mechanisms
The address size for IPv6 is 128 bits, instead of 32 bits for IPv4. This solves the problem of
limited address space and offers much simpler address configuration.
The TCP/IP stack of the IPC@CHIP works as a dual layer stack. If the IPv6 protocol is
enabled on the IPC@CHIP, all TCP/IP applications (e.g. HTTP, Telnet or FTP servers) are
accessible via both IPv4 and IPv6. The provided socket interface supports both protocol types.

For more information on IPv6 on the IPC@CHIP please refer to the IPv6 section of the
@CHIP-RTOS API documentation.
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4

Appendix - Where to get further Information

4.1

Getting Started
All software referred to in this document can be downloaded from out Getting Started website
at http://www.beck-ipc.com/gettingstarted.

4.2

Updates, tools and examples
Regularly check out IPC@CHIP website at http://www.beck-ipc.com/ipc for:
• @CHIP RTOS updates
• New APIs
• Example programs that you may use as a base for your own applications
• Useful tools for your development
• Application notes

4.3

Support
If you need support please…
1. Check our support website at http://www.beck-ipc.com/ipc/support including a FAQ.
2. Visit our newsgroup at http://www.beck-ipc.com/ipc/support/forum. Here you will find a lot
of answers to customer problems and you can also add your own ideas and questions.
3. Contact our support at support@beck-ipc.com. Of course you may also contact us by
phone. But please use email if possible. This not only reduces the time you spend on the
phone, it also allows us to easily manage the questions and identify problem areas.
Important or frequent questions and the corresponding answers are becoming part of our
FAQ that is published on the Internet.

4.4

Order numbers
Most parts of the Development Kit DK61 can be ordered separately. Please visit our online
shop. These are the order numbers.

DK61 Development Kit
DK60 Development Board
ZK14 serial null-modem cable
PSE10 power supply
Paradigm C++ Beck Edition

542750
542751
195837
538934
541522

End of this document
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